apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Malo ...@perlig.de>
Subject Re: svn commit: r330141 - /apr/apr-util/trunk/dbd/apr_dbd.c
Date Tue, 01 Nov 2005 22:54:18 GMT
* Nick Kew wrote:

> On Tuesday 01 November 2005 22:44, André Malo wrote:
> > * niq@apache.org wrote:
> > > +#define CLEANUP_CAST (apr_status_t (*)(void*))
> >
> > Hmm. That looks strange to me. Wouldn't a typedef (+ casts in place)
> > serve better?
>
> Huh?  It is a cast.  No more, no less.

Yep. I'd do it in place anyway. The macro actually decreases readability 
here (IMHO, of course ;-).

Further thinking, the typedef is actually missing in apr_pools.h. Not sure 
about the policy - could this be added for the next APR version?

nd
-- 
"Das Verhalten von Gates hatte mir bewiesen, dass ich auf ihn und seine
beiden Gefährten nicht zu zählen brauchte" -- Karl May, "Winnetou III"

Im Westen was neues: <http://pub.perlig.de/books.html#apache2>

Mime
View raw message