apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sive Lindmark <s...@capestream.se>
Subject MacOS 10.4.x data > 64k problem
Date Fri, 05 Aug 2005 13:25:05 GMT
Hi!

I send this question to the modPerl  list.

> Have used mod_perl 2.0 and newer  for a while and it have worked very 
> well on Mac OS X and Free BSD servers. Now on a Xserve with Mac Os 
> 10.4 the following happens. Requesting a web page with little contents 
> works okey but an bigger contents the loading always stops in the 
> middle with the following error message in error_log.
> (35)Resource temporarily unavailable: core_output_filter: writing data 
> to the network
> The error is coming in different places in the code but always about 
> half the page so searching the web I found some stuff. "There is a bug 
> in APR 0.9.6 that is present when it is running on Tiger, and shows up 
> when you attempt to check out a file larger than 64K." 
> http://subversion.tigris.org/faq.html#tiger-apr-0.9.6'
> If this the cause of our problem I sought that by installing the 
> latest versions of mod_perl and apache2 (SERVER_SOFTWARE = 
> Apache/2.1.6 (Unix) mod_perl/2.0.2-dev Perl/v5.8.6) could fix 
> this.....  but no
> I also tried setting a environment variable  before configuring Apache 
> and modPerl2 suggested as fix above.
> "Currently, the best solution is to rebuild Apache from their 
> respective sources, setting the following environment variable before 
> running configure for Apache in Bourne shell syntax, like this: 
> ac_cv_func_poll=no; export ac_cv_func_poll     "
> Now I have no more ideas about what to do....  any suggestions?

and a answer was that it seams to be a bug in libapr .. and I should 
try the latest code from the APR project. So I tried .. but could not 
get the latest snabshoot apr_20050804222905.tar.gz working with apache 
...

/usr/local/apr/build-1/libtool --silent --mode=compile gcc -g -O2    
-DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp    
-I/Users/boka/httpd-2.1.6-alpha/srclib/pcre -I. 
-I/Users/boka/httpd-2.1.6-alpha/os/unix 
-I/Users/boka/httpd-2.1.6-alpha/server/mpm/prefork 
-I/Users/boka/httpd-2.1.6-alpha/modules/http 
-I/Users/boka/httpd-2.1.6-alpha/modules/filters 
-I/Users/boka/httpd-2.1.6-alpha/modules/proxy 
-I/Users/boka/httpd-2.1.6-alpha/include 
-I/Users/boka/httpd-2.1.6-alpha/modules/generators 
-I/Users/boka/httpd-2.1.6-alpha/modules/mappers 
-I/usr/local/apr/include/apr-1 -I/usr/local/apache2/include 
-I/Users/boka/httpd-2.1.6-alpha/modules/proxy/../generators 
-I/Users/boka/httpd-2.1.6-alpha/modules/ssl 
-I/Users/boka/httpd-2.1.6-alpha/modules/dav/main  -prefer-non-pic 
-static -c exports.c && touch exports.lo
exports.c:1572: error: redefinition of 'ap_hack_apr_allocator_create'
exports.c:687: error: previous definition of 
'ap_hack_apr_allocator_create' was here
exports.c:1573: error: redefinition of 'ap_hack_apr_allocator_destroy'
exports.c:688: error: previous definition of 
'ap_hack_apr_allocator_destroy' was here

Is there a fix out for the MacOS 10.4.x .... data > 64k ... problem in 
the latest code? and if it is ... can anyone give me a hint how to get 
Apache2 work with this new code=

Thanks in forehand and have a nice day!

Sive
Mime
View raw message