apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn Schrader <gsch...@ll.mit.edu>
Subject Re: [PATCH] apr-util build fails on Solaris 2.8
Date Fri, 05 Aug 2005 20:15:40 GMT
Joe Orton wrote:
> On Fri, Aug 05, 2005 at 11:21:05AM -0400, Glenn Schrader wrote:
> 
>>I'm attempting to build apr-util 1.1.2 on Solaris 2.8 with
>>--enable-static, --disable-shared, and --with-berkeley-db=<path>.
>>The configuration script indicates that it can't find a
>>good Berkeley DB. The problem isn't that its not pointing
>>to a good libdb since the log file says that the test
>>for the database is failing to link because fdatasync
>>is undefined. What I've found is that on linux, fdatasync
>>appears to be in both libc and librt but on Solaris 2.8
>>its only in librt. The attached patch modifies
>>apr-util/build/apu-hits.m4 to add -lrt to the list of
>>libraries to be linked in for Solaris2.
> 
> 
> If a static BDB library can depend on -lrt then the correct way to fix 
> this is to enhance the APU_CHECK_BERKELEY_DB macro (build/bdb.m4) to 
> trying linking against -ldb -lrt if linking against -ldb fails.
> 
> joe
> 
> 
OK. That does sound cleaner (be gentle, this is the first patch that
i've submitted here). An updated patch is attached.

-glenn

Mime
View raw message