apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brad Nicholes" <bnicho...@novell.com>
Subject APR 1.2.0 build broken on NetWare (Re: [VOTE] APR 1.2.0)
Date Wed, 20 Jul 2005 19:17:24 GMT
  I'm not sure how to fix it.  There was a reason why I had to compile
the Ldap support into a separate library before linking the whole thing
together but sitting here at ApacheCon, its not coming to me right at
the moment.  Any how, my concern is that even if I can fix the apr build
files to not require the prebuilt apuldap library, ldap support on
NetWare would be broken anyway due to the fact that there was a good
reason why I patched the make files to build the library in the first
place.  I still think that it would be easier to release at least a
1.2.0 version of APU with the ldap patches folded in and anything else
that might be good to go.

Brad

>>> On Wednesday, July 20, 2005 at 11:54 am, in message
<42DE8FCE.8030103@force-elite.com>, Paul Querna <chip@force-elite.com>
wrote:
> Brad Nicholes wrote:
>> -1 Netware.  I am having build problems because of the complicated
way
>> that apr and apr-util build together on NetWare.  The problems are
>> solved if we release a new apr-util as well.  I had to change the
way
>> NetWare builds the ldap portion of apr-util and without the updates
that
>> are in trunk for apr-util, the ldap library is missing when it
comes
>> time to link the whole thing together.
>> 
>> Brad
> 
> Dang, that sucks.
> 
> Any idea how hard it is to fix?  I do sort of consider this a show
> stopper to APR (and hence, for httpd).
> 
> Any chance it can be fixed this week?
> 
> Thanks,
> 
> Paul

Mime
View raw message