apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tommi Mäkitalo <to...@epgmbh.de>
Subject Re: problem compiling apr-util-1.1.2 with suse 9.3 x86-64
Date Sat, 07 May 2005 19:43:58 GMT
Hi,

some more investigation:

it looks like the problem is in build/apu-conf.m4. There is a definition for 
APU_TEST_EXPAT, which looks for existence of /usr/lib/libexpat.la. This file 
exists in my system (SuSE 9.2 x86-64 - not 9.3 as I mentioned before - sorry 
- I'm just used to use the most recent version;-).

APU_TEST_EXPAT looks later in /usr/lib64, but not here, because it was already 
successful.

The solution is to try out the library. A minimal program ("int main() {}") 
linked with /usr/lib/libexpat.la will fail.

Mime
View raw message