apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: apr_brigade_move
Date Mon, 25 Apr 2005 21:34:36 GMT
On Mon, Apr 25, 2005 at 02:53:10PM -0400, Bill Stoddard wrote:
> Paul Querna wrote:
> >Another thing to consider is naming it 'apr_brigade_shift_head", because
> >it 'shifts' all of the buckets from source onto the head of the
> >destination.  Then you could have an 'apr_brigade_shift_tail'... etc.
> >
> >Comments?
> 
> Problems with dest and source bucket pool lifetimes?

Yes, it needs an explicit docstring that the caller must guarantee these
are correct, to make it clear when to use ap_save_brigade and when this.

I prefer the name "apr_brigade_divide" or _bisect or some synonym of
split, as the *buckets* are being moved not the brigade, but otherwise
+1.  (And really this is what _split should have been in the first
place, isn't hindsight great ;)

Regards,

joe


Mime
View raw message