apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Walter <j...@404ster.com>
Subject Re: apr_global_mutex_create never returns
Date Fri, 07 Jan 2005 18:54:45 GMT
I compiled my module with -g then used gdb.  As the none of Apache was 
built with -g, the output was somewhat... vague.  I'm going to compile 
another Apache with -g for everything, which should help yield better 
results.

Jeff Walter

(gdb) run
The program being debugged has been started already.
Start it from the beginning? (y or n) y
Starting program: /usr/sbin/apache2 -k start -X
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...
Detaching after fork from child process 26204.

Program received signal SIGSEGV, Segmentation fault.
0x4027306e in apr_global_mutex_create () from /usr/lib/libapr-0.so.0
(gdb) bt
#0  0x4027306e in apr_global_mutex_create () from /usr/lib/libapr-0.so.0
#1  0x080a20f0 in ?? ()
#2  0x081affd0 in ?? ()
#3  0x40272f80 in apr_version_string () from /usr/lib/libapr-0.so.0
#4  0x080603b8 in ?? ()
#5  0x408c8974 in __JCR_LIST__ () from /usr/lib/apache2/modules/mod_straw.so
#6  0x080f5ea0 in ?? ()
#7  0x080a3e90 in ?? ()
#8  0x408c6cdb in straw_post_config (pconf=0x80a20f0, plog=0x80cc198, 
ptemp=0x80bc158, s=0x80a3e90) at mod_straw.c:344
#9  0x08068549 in ap_run_post_config ()
#10 0x080cc198 in ?? ()
#11 0x080bc158 in ?? ()
#12 0x080a3e90 in ?? ()
#13 0x0809c050 in ?? ()
#14 0x081d8448 in ?? ()
#15 0x08182b78 in ?? ()
#16 0x080a3e90 in ?? ()
#17 0x080a20f0 in ?? ()
#18 0x080a0168 in ?? ()
#19 0xbffffb58 in ?? ()
#20 0x0806e145 in main ()


Mime
View raw message