apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jus...@erenkrantz.com>
Subject Re: v0.9 and v1.x simultaneously - Expat conflict
Date Mon, 17 Jan 2005 18:03:34 GMT
On Mon, Jan 17, 2005 at 01:46:22PM -0000, Max Bowsher wrote:
> Graham Leggett wrote:
> >Hi all,
> >
> >Both v0.9 and v1.x of apr-util include a bundled copy of expat v1.95.2.
> >
> >When you try and install both the v0.9 and v1.x apr-util libraries at the
> >same time, a conflict results as the same expat libraries are installed
> >twice in the same place.
> >
> >Is it necessary to bundle expat at all?
> >
> >How would somebody doing packaging handle expat if it were bundled with
> >apr-util?
> 
> I'd say that anyone doing packaging should be externally packaging an xml 
> parser, and that bundled dependencies are a convenience accomdation for 
> ad-hoc /usr/local installs.

If you pass --with-expat or configure can find the installed expat, it'll use
that over the bundled copy.  So, yes, I agree that the packager should be
dealing with this explicitly.  But, we can't assume the from-source user has
expat installed.  -- justin

Mime
View raw message