apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: LDAP changes in apr-util 1.0.x
Date Wed, 05 Jan 2005 16:35:23 GMT
On Wed, Jan 05, 2005 at 05:32:48PM +0200, Graham Leggett wrote:
> Joe Orton said:
> 
> > The apr_ldap_option.h interfaces can't be added in a 1.0.x release,
> > 1.0.x releases must be forward and backwards source-compatible with
> > 1.0.0 per the versioning guidelines.
> 
> Ok... I will remove the patches from the apr v1.0 tree.
> 
> This means that httpd v2.1.x now depends on apr v1.1.x - are there any
> obstacles in the way of cutting an official v1.1.0 release of APR in the
> next week or two?

I'm still catching up from holiday stuff, but I presume you do mean just
apr-util not apr?  I think it would be preferable if any dependencies on
apr{,-util}-1.1 in httpd were conditional at compile-time (using
ap?_version.h), but there should be no barriers to release other than
round tuits, unless there are any regressions recently.

If there is a hard dependency it should be enforced at configure-time
and that requires more AP?_FIND_AP? hacking I expect! (which would be
more work than just removing the dependency :)

joe

Mime
View raw message