apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject RFC: drop autoconf 2.13 support on trunk
Date Thu, 25 Nov 2004 10:44:21 GMT
I'd like to propose also to drop autoconf 2.13 support on the trunk.

This allows:
- removal of use of deprecated features like acconfig.h and hence the 
loud warnings during ./buildconf runs (this can only be done in a not-2.13-
compatible way)
- use of new features like AC_MSG_WARN
- stop abuse like changing $ac_includes_default

Impact for developers:
- you may need to upgrade autoconf 
- autoconf 2.5x requires GNU m4, 2.13 worked with native m4s

Impact for users:
- should be none, all tarballs have been built with 2.5x for a
long while anyway

joe

Mime
View raw message