apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Christie" ...@sover.net>
Subject Re: Win32 project building
Date Fri, 12 Nov 2004 08:02:26 GMT
I have had difficulties building APR 1.0.0 on Win32. I am trying to
build in the Visual Studio IDE rather than from the command line. (I have 
done this successfully before with previous releases of APR; I have 
installed awk.exe, etc.) But there seem to be some unresolved issues with 
the 1.0.0 build.

I have both Visual Studio 6.0 and Visual Studio .NET 2003 available, and 
have tried both, with similar results. Here is exactly what I got using 
Visual Studio 6.0.

I found that opening the apr-util-1.0.0/aprutil.dsw workspace and building 
as described in http://apr.apache.org/compiling_win32.html only works 
partially.

First, I had to rename the unzipped directories by removing the '-1.0.0' 
suffix before I could open the aprutil.dsw successfully.

Having done that, I tried building the static libraries, in Debug mode.

The following libraries built successfully in apr/LibD:

    apr-1.lib
    apr_app-1.lib
    apriconv-1.lib

but apr-util.lib did not; it encountered the following errors:

xlate.c
C:\ORG\apache\apr-util\xlate\xlate.c(181) : error C2198: 'apr_iconv_close' : 
too few actual parameters
C:\ORG\apache\apr-util\xlate\xlate.c(182) : error C2198: 'apr_iconv_open' : 
too few actual parameters
C:\ORG\apache\apr-util\xlate\xlate.c(182) : warning C4047: '=' : 'void *' 
differs in levels of indirection from 'int '
apr_xml.c
Generating Code...
Error executing cl.exe.

By excluding xlate.c from the build, and also the ldap_*.c files, I was able 
to get an apr-util.lib generated; there were lots of multiply defined 
warnings for symbols also defined in apr-1.lib.


Then I tried the dynamic libraries (project libaprutil). It failed 
immediately with:

--------------------Configuration: libapr - Win32 Debug-------------------
Creating apr.h from apr.hw
Creating Version Resource
Compiling resources...
C:\ORG\apache\apr\libapr.rc (3): error RC2127 : version WORDs separated by 
commas expected
C:\ORG\apache\apr\libapr.rc (3): error RC2167 : unrecognized VERSIONINFO 
field;  BEGIN or comma expected
Error executing rc.exe.

libaprutil-1.dll - 2 error(s), 0 warning(s)



Regards,

-David Christie


Mime
View raw message