apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MGorbu...@imbank.ru
Subject Re: [mp2] NetBSD-1.6.2 modperl 1.99_16 httpd 2.0.51-dev make test errors
Date Wed, 15 Sep 2004 14:11:36 GMT
Stas Bekman <stas@stason.org> wrote on 15.09.2004 18:03:35:

> 
> 
> > Warning: You do not have permissions to install into 
> > /usr/pkg/lib/perl5/site_perl/5.8.4/i386-netbsd at 
> > /usr/pkg/lib/perl5/5.8.4/ExtUtils/Install.pm line 114.
> > mkdir /usr/pkg/lib/perl5/site_perl/5.8.4/i386-netbsd/Apache2: 
Permission 
> > denied at /usr/pkg/lib/perl5/5.8.4/ExtUtils/Install.pm line 176
> > *** Error code 255
> > 
> > Stop.
> > make: stopped in /home/mgorb/mp-test/modperl-2.0
> > k714%
> > 
> > modperl was built with  MP_INST_APACHE2=1. Does it still has to 
install 
> > something into /usr/pkg/lib/perl5/site_perl/5.8.4/i386-netbsd ?
> 
> Of course. You have to be root to install things into the common area. 
> Unless you told it to use a different PREFIX (e.g. to install under you 
> $HOME), in which case it's a bug. But you need to show your 'perl 
> Makefile.PL' line then.
> 
 I thought configuring it with MP_INST_APACHE2=1 tells it to install 
everything under httpd PREFIX directory.

Mime
View raw message