apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: renaming apr_file_permissions defines
Date Sun, 19 Sep 2004 16:59:51 GMT
At 09:15 AM 9/19/2004, Greg Stein wrote:
>On Fri, Sep 17, 2004 at 09:21:17PM -0500, William A. Rowe, Jr. wrote:
>> At 07:53 PM 9/17/2004, you wrote:
>> >and the rename of apr_file_permissions group:
>> >
>> >s/APR_/APR_FILEPROT_/
>> 
>> Veto - defer for 2.0
>
>There is no reason to wait until 2.0. The versioning guidelines allow us
>to provide new symbolic names in 1.x versions.
>
>As long as APR_REG and friends exist in all 1.x versions, then everything
>is fine. If 1.1 happens to include a new APR_FILETYPE_REG, then there
>isn't a problem.

This is correct, yes.  We need to first branch APR_1_0 development
so such patches can be applied to cvs HEAD.

>IOW, I'd encourage you to reconsider your veto. I don't see the problem
>that you're trying to prevent.

I'm retracting the vetos on these three renames, provided we apply
them to APR_1_1, but I'm not 100% comfortable that our own devs
want such wordy names.  Is it wrong to have both shorthand and the
strongly-typed equivalents?  In any case, it would not be a good
idea to rename these based on minority opinion.  I'm +1 for less
ambiguous names myself.

Bill  


Mime
View raw message