apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bennett, Tony - CNF" <Bennett.T...@cnf.com>
Subject RE: Must I have LDAP for apr-util ???
Date Tue, 14 Sep 2004 02:46:17 GMT
>-----Original Message-----
>From: Graham Leggett [mailto:minfrin@sharp.fm]
>Sent: Monday, September 13, 2004 6:20 PM
>To: Bennett, Tony - CNF
>Cc: dev@apr.apache.org
>Subject: Re: Must I have LDAP for apr-util ???

>Bennett, Tony - CNF wrote:

>> I have no need for LDAP, and have tried to use the "without"
directive

>> but "configure" exits with a failure stating:
>>         configure: error: could not find an LDAP library
>> 
>> Here's my configure command:
>> 
>>     CC="xlc_r"; export CC
>>     "./configure" \
>>     "--prefix=/usr/local/dms/apr-util-1.0.0" \
>>     "--enable-threads" \
>>     "--without-ldap" \
>>     "--without-ldap-include" \
>>     "--without-ldap-lib" \
>>     "--with-dbm=sdbm" \
>>     "--without-berkeley-db" \
>>     "--with-expat=/usr/local/dms/expat" \
>>     "--with-apr=/usr/local/dms/apr" \
>
>What if you leave out the ldap stuff totally?
>
>Regards,
>Graham
>--
>-----Original Message-----
>From: Bennett, Tony - CNF [mailto:Bennett.Tony@cnf.com] 
?Sent: Monday, September 13, 2004 6:47 PM
>To: Graham Leggett
>Cc: dev@apr.apache.org
>Subject: RE: Must I have LDAP for apr-util ???
>
>Graham,
>
>I have openldap installed on my development system, but not on my
production system ... so I'm concerned that I don't 
>build in any fuctionality that'll be missing on production...

>However,
>I tried what you suggested, and omitted all of my "without-"
>directives, and configure completed successfully.
>
>Now, however, "make" is "hanging"...
>
>It is hanging running on this section of code from libtool (included
with apr-1.0.0):
>
>      until $run ln "$0" "$lockfile" 2>/dev/null; do
>        $show "Waiting for $lockfile to be removed"
>        sleep 2
>      done
> 
>The problem is that libtool is on one file system and the file to be
locked (apr_brigade.o.lock, in this case) is on 
>another filesystem....and AIX forbids cross filesystem links (although
sym-links are allowed cross filesystems).
>
>-tony

Graham,

Sorry to answer my own post, but I solved the problem
by modifying libtool to use a symlink instead of a 
normal link... and I got beyond the loop...

Now I see that the install of apr-1.0.0 did not go swimmingly...
...all of the include files were not installed...
...which causes me build problems on apr-util-1.0.0...

Specifically, make install contains the following commands:

    build/install.sh -c -m 644
/home/trbennet/apr/apr-1.0.0/include/apr.h
/usr/local/dms/apr-1.0.0/include/apr-1
    build/install.sh -c -m 644
/home/trbennet/apr/apr-1.0.0/include/apr_*.h
/usr/local/dms/apr-1.0.0/include/apr-1 

The first one worked just fine, but the second one failed...
...I think the problem is that build/install.sh cannot handle wildcards
in the file parameters...

Any suggestions ????

Thanks,
-tony

Mime
View raw message