apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bennett, Tony - CNF" <Bennett.T...@cnf.com>
Subject RE: Must I have LDAP for apr-util ???
Date Tue, 14 Sep 2004 01:46:50 GMT
Graham,

I have openldap installed on my development system,
but not on my production system ... so I'm concerned that
I don't build in any fuctionality that'll be missing on
production...

However,
I tried what you suggested, and omitted all of my "without-"
directives, and configure completed successfully.

Now, however, "make" is "hanging"...

It is hanging running on this section of code
from libtool (included with apr-1.0.0):

      until $run ln "$0" "$lockfile" 2>/dev/null; do
        $show "Waiting for $lockfile to be removed"
        sleep 2
      done
 
The problem is that libtool is on one file system
and the file to be locked (apr_brigade.o.lock, in this case)
is on another filesystem....and AIX forbids cross filesystem
links (although sym-links are allowed cross filesystems).

-tony

-----Original Message-----
From: Graham Leggett [mailto:minfrin@sharp.fm] 
Sent: Monday, September 13, 2004 6:20 PM
To: Bennett, Tony - CNF
Cc: dev@apr.apache.org
Subject: Re: Must I have LDAP for apr-util ???

Bennett, Tony - CNF wrote:

> I have no need for LDAP, and have tried to use the "without" directive

> but "configure" exits with a failure stating:
>         configure: error: could not find an LDAP library
> 
> Here's my configure command:
> 
>     CC="xlc_r"; export CC
>     "./configure" \
>     "--prefix=/usr/local/dms/apr-util-1.0.0" \
>     "--enable-threads" \
>     "--without-ldap" \
>     "--without-ldap-include" \
>     "--without-ldap-lib" \
>     "--with-dbm=sdbm" \
>     "--without-berkeley-db" \
>     "--with-expat=/usr/local/dms/expat" \
>     "--with-apr=/usr/local/dms/apr" \

What if you leave out the ldap stuff totally?

Regards,
Graham
--

Mime
View raw message