apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <...@manyfish.co.uk>
Subject Re: 1.1.0 RCx configure error
Date Mon, 27 Sep 2004 21:36:23 GMT
On Mon, Sep 27, 2004 at 09:48:00PM +0100, Barry Scott wrote:
> I just noticed the follow when I configure RC3 or RC4 on FreeBSD 4.10 
> Release
> 
> checking for utimes... yes
> /u/barry/subversion/FreeBSD_torment/subversion-1.1.0-rc4/apr/configure: 
> line 17796: test: 4.10-RELEASE: integer expression expected
> checking for sigaction... yes
> 
> do you need a bug report?

Yes please, at http://issues.apache.org/bugzilla/enter_bug.cgi?product=APR

The os_version code did not anticipate two-digit minor versions, no idea
what the best fix is...

case $host in
    *freebsd*)
        # 3.4-RELEASE: 340   4.1.1-RELEASE: 411
        os_version=`uname -r | sed -e 's/\(.\)\.\(.\)\.\(.\).*/\1\2\3/' | sed -e 's/\(.\)\.\(.\)\-.*/\1\20/'`
 
joe

Mime
View raw message