apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark <m...@giddieup.net>
Subject Re: apr compiling errors
Date Thu, 23 Sep 2004 18:33:46 GMT
any other ideas? 
gcc seems to be working for all my other apps..yesterday i just compiled bdb for something
else and it didn't complain about ld or gcc


On Sep22, 14:35, Mark wrote:
> On Sep22, 22:00, Joe Orton wrote:
> > On Wed, Sep 22, 2004 at 09:30:15PM +0100, Joe Orton wrote:
> > > On Wed, Sep 22, 2004 at 12:32:29PM -0700, Mark wrote:
> > > > checking for MAP_ANON in sys/mman.h... yes
> > > > checking for /dev/zero... yes
> > > > ./configure:Error: decision on anonymous shared memory allocation method
failed
> > > 
> > > If you are using apr from an httpd tarball, then what version?  Please
> > > upload the config.log somewhere so we can have a look at it.
> > 
> > The config.log Mark sent me had:
> > 
> > configure:16382: checking for mmap
> > configure:16432: gcc -o conftest -g -O2 -pthreads -DSOLARIS2=8 
> > -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT  conftest.c -lm
> > +-lsocket -lns
> > l -lresolv  -lpthread >&5
> > collect2: ld terminated with signal 11 [Segmentation Fault], core dumped
> > configure:16435: $? = 1
> > 
> > is there a reason you passed --with-gnu-ld to configure?  I'd try it
> > without.  Otherwise, it looks like you have a broken GCC installation. 
> > Can you compile simple programs with it?
> > 
> > joe
> 
> i tried without the tag as well..but didnt work....
> 
> gcc does compile other programs without problems......

Mime
View raw message