apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Havard" <bri...@kheldar.apana.org.au>
Subject Re: Autoconf breakage
Date Sat, 07 Aug 2004 03:44:31 GMT
On Sat, 07 Aug 2004 07:14:46 +1000, Ian Holsman wrote:

>Justin Erenkrantz wrote:
>> --On Wednesday, August 4, 2004 10:36 PM +1000 Brian Havard 
>> <brianh@kheldar.apana.org.au> wrote:
>> 
>>> I just tried buildconf'ing apr-util and got this
>>>
>>> Looking for apr source in ../apr
>>> Creating include/private/apu_config.h ...
>>> Creating configure ...
>>> autoconf: Undefined macros:
>>> ***BUG in Autoconf--please report*** AC_WARNING
>>> autoconf failed
>>>
>>> Is AC_WARNING a 2.5x macro?
>>> I can only find one occurance of it in find_apr.m4, added a few days ago.
>> 
>> 
>> Perhaps.  *sigh*  Can you try replacing AC_WARNING with AC_WARN to see 
>> if the error goes away?  I'm fairly sure that it won't do the 'right' 
>> thing though. We could always suppress the warning/error if AC_WARNING 
>> isn't defined.
>> 
>
>$ autoconf --version
>Autoconf version 2.13
>
>...
>
>Looking for apr source in ../apr
>Creating include/private/apu_config.h ...
>Creating configure ...
>autoconf: Undefined macros:
>***BUG in Autoconf--please report*** AC_WARN
>autoconf failed

The 2.13 macro is actually AC_MSG_WARN but when I tried using that it still
failed while it was contained in the m4_if. Moving the line out of the
m4_if, having the $0 in there seems to cause some kind of infinite
recursion (process dies eventually from lack of memory).

-- 
 ______________________________________________________________________________
 |  Brian Havard                 |  "He is not the messiah!                   |
 |  brianh@kheldar.apana.org.au  |  He's a very naughty boy!" - Life of Brian |
 ------------------------------------------------------------------------------


Mime
View raw message