apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject make install doesn't update the .so.0 symlink
Date Sun, 29 Aug 2004 16:52:30 GMT
It took me a while to figure out what was the problem with some 3rd party 
library using libapr. Eventually I've discovered that the libapr-0.so.0 
symlink wasn't getting updated on 'make install', the old link to an older 
library was kept intact. Is it a bug?

/home/stas/httpd/prefork/lib> ls -l libapr-0.so.0
lrwxrwxrwx  1 stas stas 17 Aug 29 12:34 libapr-0.so.0 -> libapr-0.so.0.9.5
/home/stas/httpd/prefork/lib> cp libapr-0.so.0.9.5 libapr-0.so.0.9.5-old
/home/stas/httpd/prefork/lib> ln -sf libapr-0.so.0.9.5-old libapr-0.so.0
/home/stas/httpd/prefork/lib> ls -l libapr-0.so.0
lrwxrwxrwx  1 stas stas 21 Aug 29 12:49 libapr-0.so.0 -> libapr-0.so.0.9.5-old

/home/stas/httpd/prefork/lib> cd /home/stas/apache.org/httpd-2.0
/home/stas/apache.org/httpd-2.0> make install
/home/stas/apache.org/httpd-2.0> cd /home/stas/httpd/prefork/lib

/home/stas/httpd/prefork/lib> ls -l libapr-0.so.0
lrwxrwxrwx  1 stas stas 21 Aug 29 12:49 libapr-0.so.0 -> libapr-0.so.0.9.5-old

shouldn't the link go back to libapr-0.so.0.9.5?

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message