apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jus...@erenkrantz.com>
Subject Re: [PATCH] update find_ap{ru}.m4 for ap{ru}-1-config was Re: 1.0.0 RC4 (apr-config -> apr-1-config)
Date Thu, 15 Jul 2004 15:06:32 GMT
--On Thursday, July 15, 2004 10:38 AM +0100 Max Bowsher <maxb@ukf.net> wrote:
> 1) It doesn't update configure.in / Makefile.in to name apr-config
> apr-MAJOR-config in the build directory.

Well, that doesn't matter to our external projects.  (And, huh, it's already 
named like that for me when it's installed.)

> 2) It assumes bundled apr will be apr-1. We want to make find_apr.m4
> independent of apr version, so that in the future, it could be installed
> into a system aclocal directory (thanks to noahmcit on #apr for pointing
> this out).

No, that doesn't matter: if you want to assume bundled APR is less than 1.0, 
use the same find_ap{ru}.m4 you are right now.

> 3) It only implements "accept apr-0 or apr-1", but unless projects do extra
> compatibility work, and make sure to *never* expose the apr ABI in their own
> ABI, they will want "accept apr-0 only" or "accept apr-1 only".

Again, not a concern at all.  If you want to accept apr-0 *only*, then don't 
upgrade to this find_ap{ru}.m4.

It's not like all of the projects would magically upgrade to this: they have 
to choose to upgrade to this m4 version.  -- justin

Mime
View raw message