apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Reid" <da...@jetnet.co.uk>
Subject Re: 1.0.0 RC4
Date Wed, 14 Jul 2004 08:26:13 GMT
> --On Tuesday, July 13, 2004 8:32 PM -0700 Paul Querna
<chip@force-elite.com>
> wrote:
>
> > Failed on FreeBSD 5.2.1-p7:
> > When '--enable-threads' is passed, the final shared object does not link
> > against libc_r:
> >
> >  $ ldd .libs/libapr-1.so.0
> >   .libs/libapr-1.so.0:
> >           libcrypt.so.2 => /lib/libcrypt.so.2 (0x28176000)
>
> It's a bug in the libtool that David rolled with (not a 'bug' but a
'feature'
> in libtool as they try to be our nanny).  It strips out libc_r (see around
> line 1358 in David's libtool version).

I actually uninstalled libtool 1.5 from my box and then installed libtool
1.4 before starting to roll the tarballs following Joe Orton's advise that
libtool 1.5 had issues. Go figure.

> However, libtool 1.5.6 from /usr/ports works fine for me (re-run
buildconf).
> We could either document it (as you have to pass --enable-threads to
trigger
> this), or try to upgrade the libtool we roll with.  IIRC, there are some
> reasons why we've been avoiding upgrading to 1.5 - so I recommend we
document
> 1.4.3 with --enable-threads on FreeBSD 5.2 is busted for 1.0.0 and figure
out
> libtool 1.5+ for APR 1.1 (or 1.0.1) at this stage of the game.  -- justin

I think we should just document this. People can re-run buildconf if they're
on a 5.2.1 system after all.

david


Mime
View raw message