apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: documented 1.0 showstoppers
Date Mon, 07 Jun 2004 14:02:12 GMT
At 03:33 PM 6/4/2004, Stas Bekman wrote:

>Thanks Noah, but this is exactly why I didn't do that and asked here first. It's not about
just changing the API, since you will break any application that relies on that. You must
provide backwards compatibility which should be deprecated and will be cut off at 1.0 release.
That's the part I'm not sure about.

Actually, here you don't.

Since this change is only for 1.0 - and doesn't need to (and shouldn't) 
be applied to 0.9 - there is no thunk/compat required.  You mention you
*need* it for 0.9.x - there you lost me.  For 0.9.x (ignore all that odd
__attribute__((deprecated)) - since we have @deprecated doxygenation),
simply #define both.

Bill  


Mime
View raw message