apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stas Bekman <s...@stason.org>
Subject Re: documented 1.0 showstoppers
Date Tue, 08 Jun 2004 13:42:53 GMT
William A. Rowe, Jr. wrote:
> At 03:33 PM 6/4/2004, Stas Bekman wrote:
> 
> 
>>Thanks Noah, but this is exactly why I didn't do that and asked here first. It's not
about just changing the API, since you will break any application that relies on that. You
must provide backwards compatibility which should be deprecated and will be cut off at 1.0
release. That's the part I'm not sure about.
> 
> 
> Actually, here you don't.
> 
> Since this change is only for 1.0 - and doesn't need to (and shouldn't) 
> be applied to 0.9 - there is no thunk/compat required. 

Understood.

> You mention you
> *need* it for 0.9.x - there you lost me.  For 0.9.x (ignore all that odd
> __attribute__((deprecated)) - since we have @deprecated doxygenation),
> simply #define both.

Ah, right. For some reason I thought that you need to do something special 
because it's enum.

Thanks Bill!

-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Mime
View raw message