apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Reid" <da...@jetnet.co.uk>
Subject Re: 1.0 rc2 Tarballs
Date Wed, 30 Jun 2004 13:11:06 GMT
> At 07:06 AM 6/30/2004, David Reid wrote:
>
> >I haven't done apr-iconv as Will Rowe had some reservations about that
> >module. If someone who's more familiar wants to roll a tarball that's
> >compatible with rc2 that'd be great.
>
> Doesn't matter - now that you've tagged apr-util-1.0.0 - we are locked
> into using that apr-iconv interface period for apr-iconv-1.0.0.
>
> All I'd suggested at this juncture is to add some notatation that the
> apr_iconv_ functions are private interfaces, e.g.
>
>   @deprecated Private Interface!  See the apr-util apr_xlate.h API.

Sure. Works for me.

> Can we get some +1's on this?

+1 from me.

> IMHO we can't release this tarball without moving to apr-1-config
> as mentioned in the apr pkgconfig thread.  This allows us to have
> 0.9 and 1.0 installed side by side, e.g. if httpd and svn users are
> building both older and newer software.  While they cannot be
> installed side by side, I'm -1 for release; once addressed I'm +1.

I'm assuming that this is a reasonably trivial change that hopefully someone
will make while I disappear off to work!

david


Mime
View raw message