apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@attglobal.net>
Subject Re: getaddrinfo() on HP-UX 11i
Date Fri, 20 Feb 2004 20:38:28 GMT
Mathihalli, Madhusudan wrote:
>>-----Original Message-----
>>From: Jeff Trawick [mailto:trawick@attglobal.net]
> 
> [SNIP]
> 
>>>libc patch with IPv6 support - PHCO_24400 
>>>libc headerfile patch with IPv6 support - PHCO_24402 
>>>libnss_files patch with IPv6 support - PHCO_24401 
>>>libnss_dns patch with IPv6 support - PHNE_24129
>>>All these patches or their superseding patches should be 
>>
>>installed for
>>
>>>getaddrinfo to work on 11i.
>>
>>This box has PHC0_24402 installed but none of the others.
>>
>>/usr/lib/libc.a definitely has a getaddrinfo().
>>
>>I have the feeling that PHC0_24402 got installed because some 
>>other libc fix 
>>(perhaps needed by java) needed it.  Do you know of a way to 
>>find what patches 
>>require PHC0_24402, and also to find which files are modified 
>>by PHC0_24402?
> 
> 
> I don't know how you can get the details from outside-hp (I'll 
 >have to ask somebody), but I have access to a internal tool that
 >can give the required info. about - here's the information you
 >requested:

> 
> Files modified by PHCO_24402:
> /usr/include/arpa/nameser.h
> /usr/include/arpa/nameser_compat.h
> /usr/include/netdb.h
> /usr/include/time.h

Since PHC0_24402 didn't add getaddrinfo to libc.a and I don't have those other 
patches installed but libc.a has getaddrinfo, then there must be other ways 
than the documented patch sets to get libc.a to support getaddrinfo.

I must have a patch that supercedes PHCO_24400 and includes the getaddrinfo 
update to libc but which does not prereq the rest of the stuff that is required 
to make getaddrinfo() work.

Thanks for your help,

Jeff


Mime
View raw message