apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <jor...@redhat.com>
Subject Re: apr/apr-util python dependence
Date Fri, 20 Feb 2004 10:31:25 GMT
On Fri, Feb 20, 2004 at 11:27:29AM +0100, Sascha Schumann wrote:
>     Please get your facts straight.
> 
> > > httpd is still just as "buildable" on such platforms regardless of
> > > gen-build.py: from the release tarballs.  Building from a CVS checkout
> > > cannot be done without extra tools, but that has always been true in
> > > 2.0: you need libtool and autoconf (not to mention the CVS client).
> > > Hell, autoconf itself has required Perl and GNU m4 for the last
> > > three-odd years.
> 
>     autoconf does not use perl.

It has done since 2.50 AFAIK: from the README in 2.59:

""
Producing configuration scripts using Autoconf requires GNU M4 and
Perl.  You must install GNU M4 (version 1.4 or later) and Perl (5.005_03
or later) before configuring Autoconf, so that Autoconf's configure
script can find them.  The configuration scripts produced by Autoconf
are self-contained, so their users do not need to have Autoconf (or
GNU M4, Perl etc.).
""

joe

Mime
View raw message