apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Querna <c...@force-elite.com>
Subject Re: apr/apr-util python dependence
Date Fri, 20 Feb 2004 09:17:32 GMT

> httpd is still just as "buildable" on such platforms regardless of
> gen-build.py: from the release tarballs.  Building from a CVS checkout
> cannot be done without extra tools, but that has always been true in
> 2.0: you need libtool and autoconf (not to mention the CVS client). 
> Hell, autoconf itself has required Perl and GNU m4 for the last
> three-odd years.

Then the decision is made right there. Apache requires libtool to build
from CVS. Libtool Requires Perl.  Instead of writing it in Python, do it
in Perl.  Perl is a higher enough level language and it should be easy
to maintain.  If you are on a platform without Perl, you won't have
libtool anyways. Right?

This adds no further dependencies for building Apache from CVS, and
allows use of a higher level language.  So, why not rewrite it in Perl
instead of degrading it into shell crap that is hard to maintain and add
features to?  This seems like a sensible solution to me.

-Paul Querna


Mime
View raw message