apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From G√ľnter Knauf <efl...@gmx.net>
Subject Re: what about 2.1.0 ?????
Date Fri, 16 Jan 2004 22:01:29 GMT
Hi,
> Although it is late, a relatively small number of boxes would be
> affected...
right.

> ... should we modify the installed library name libapr-1.so to designate
> that the
> user is running a dev (non-release) version when using an arbitrary CVS
> checkout?  Something like libapr-dev-1.so?
I really appreciate that you want to take care of that, but this would only help on Unix,
on other platforms I think it's too complicated/impossible to do such protection, or...?

> This would prevent production applications from linking against a
> (potentially) unstable code point.
hmm, I feel a bit that sometimes you wanna be too perfect; I think that often ASF alpha code
is better than what others call releases, and in the httpd-2.0 alpha phase there were even
a few already using it in production...

I believe that the code becomes quicker more stable if people start using it; 
and often the user stresses the software in another way then what the developer might imagine...

Guen.



Mime
View raw message