apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roy T. Fielding" <field...@gbiv.com>
Subject Re: [PATCH] Convenience macros for apr array manipulation
Date Sat, 13 Dec 2003 00:38:53 GMT
>> +#define APR_ARRAY_PUSH(arr, type, item) \

A macro that is intended to mimic the behavior of a function call
should always be named in the same way as function calls, not with
all-uppercase names.  Stuff like the above makes the interface
entirely dependent on the implementation, and makes the code harder
to read for no reason.


View raw message