apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anthony Howe <ach...@snert.com>
Subject Re: apr_global_mutex_child_init & mod_watch
Date Sun, 07 Sep 2003 21:55:19 GMT
G√ľnter Knauf wrote:

>>Anthony Howe wrote:
> 
> 
>>>Since Apache 2.0.46, mod_watch has no longer worked. The
>>>apr_global_mutex_child_init() consistantly fails and now I'm finally
>>>trying to get mod_watch/4 working again.
> 
> I've also tried Anthony's module on Win32, and while it seems to work with 2.0.47 on
W2K it fails on WXP.
> I guess that on WXP the child doesnt inherit the rights and so cant create the needed
files...

I would expect that the current problems are related to the traditional 
prefork MPM, and resources ownership on Unix-like systems. On W2K, the 
problem would be different since you'd most likely use a threaded model 
instead of a process-farm model. WXP should be no difference from W2K in 
this respect so I don't understand the reasons for the failure in that 
environment.

My immediate concern is with the traditional prefork MPM in Unix-land 
which is my base line. I haven't updated the mod_watch source since 
2.0.44 when it was know to work in Feburary / March. Since then 
something fundumental has changed in the Apache / APR / unix support. 
I've found that if I comment out the apr_global_mutex_child_init() call, 
everything works otherwise I get a "permission denied" error code every 
time a child process starts.

-- 
Anthony C Howe                                 +33 6 11 89 73 78
http://www.snert.com/       ICQ: 7116561         AIM: Sir Wumpus
"                                                " - Zen thought


Mime
View raw message