apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jus...@erenkrantz.com>
Subject Re: cvs commit: apr configure.in CHANGES
Date Mon, 25 Aug 2003 16:50:53 GMT
--On Monday, August 25, 2003 12:40:47 -0400 Jeff Trawick 
<trawick@attglobal.net> wrote:

> IIRC getnameinfo() was the problem, not getaddrinfo().
>
> With 6.6 kernel (and whatever else Jaguar+latest updates gets you),
> http://www.apache.org/~trawick/gni_mapped.c still fails for me.  (This
> supposedly means that deny/allow from IP controls are broken.)  Can you
> try gni_mapped on your system?

I don't understand what gni_mapped is supposed to output.  I get the same 
output on Darwin as I do on FreeBSD.

IIRC, the root problem was that host-based authorization didn't work.  When 
IPv6 was overriden to be enabled, host-based authorization works now on 
6.6.  AFAICT, IPv4-mapped addresses look correct.  (The httpd-test 
framework passed the tests it wasn't passing a long time ago.)

I did ask for others to confirm that it worked (as it does here), but no 
one responded, so I assumed people were happy.

As for binary compatibility, I think it just means that we should probably 
stop upgrading APR in releases of httpd-2.0.  -- justin

Mime
View raw message