apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Orton <...@manyfish.co.uk>
Subject Re: [Patch] Revised fallback libtool.m4 location in buildconf
Date Tue, 17 Jun 2003 21:29:24 GMT
On Tue, Jun 17, 2003 at 10:15:32PM +0100, Max Bowsher wrote:
> Joe Orton wrote:
> > Hi Max,
> >
> > On Tue, Jun 10, 2003 at 07:09:48PM +0100, Max Bowsher wrote:
> >> Below are the patches, one to apr and one to apr-util, revised to use
> >> PrintPath.
> >
> > I think it's useful to allow finding libtool.m4 in odd places without
> > requiring an aclocal installation - since this can be done with a very
> > simply change I've committed it rather than your patch. Hope this works
> > for you: just set $LIBTOOL_M4 appropriately.
> It's a slight improvement, but not by much.
> This means that every user of any distribution using auto-version-selecting
> autotool wrappers will need to set an environment variable.

Ah, does CygWin use an autoconf wrapper which tries to guess whether it
should use 2.5x or 2.13 like Debian do/did? 

> This is like configure asking you to manually set things which it could test
> for.
> Shall I redo my patch to incorporate use of the LIBTOOL_M4 variable, or is
> the idea of using aclocal, even only optionally, simply not acceptable for
> some reason?

I don't care strongly either way about the aclocal patch either way, so
I didn't commit it.  If someone else wants to commit it they don't need
my approval. :)



View raw message