apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Gough" <igo...@gridironsoftware.com>
Subject v0.9.2 apr-iconv does not build. required for apr-util?
Date Wed, 23 Apr 2003 18:26:28 GMT
Hi,
 
I am having a bit of a problem getting apr-iconv v0.9.2 to build on RH
Linux 7.3 and Mac OS X 10.2. Is this package required to build apr-util?
 
The config file on Linux seems to be able to find the native iconv, so I
suspect it isn't required there, but no equivalent is found on Mac OS X.
 
The problem seems to be that the apr-iconv configure script is expecting
libtool 1.3 (looking for ltconfig) but these platforms use libtool and
glibtool 1.4.2, which does not have ltconfig. Since this seems to be an
obvious problem, I can only assume that I am doing something stupidly
wrong trying to build APR. Can somebody verify that these are the
correct steps:
 
cd apr
./configure
make
make install
cd ../apr-iconv
./configure
make
make install
cd ../apr-util
./configure --with-apr=/usr/local/apr
make
make install
 
And here are the final few lines of output from running configure in
apr-iconv on Mac OS X:
 
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/bin/ld) supports shared libraries...
yes
checking how to hardcode library paths into programs... unsupported
checking whether stripping libraries is possible... no
checking dynamic linker characteristics... darwin6.4 dyld
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
creating libtool
/Users/igough/src/revgen/xGrid/apr/build/ltconfig:
/Users/igough/src/revgen/xGrid/apr/build/ltconfig: No such file or
directory
./configure: /Users/igough/src/revgen/xGrid/apr/APRVARS: No such file or
directory


Mime
View raw message