apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trevor Hurst <t...@sgi.com>
Subject Build problems with apr-util-0.9.1 src
Date Tue, 25 Feb 2003 21:46:01 GMT

Hello,

I am in need of building the apr-util source because a
project of mine requires that I build auth-ldap into 
my Apache 2.0.44 server.

System is running IRIX 6.5.19 with all of the tools;

I have autoconf and automake installed and gnu make
as well as all the other gnu tools like gcc and gnu
libtool, etc ,etc.. 

My problem appears to be that when I run ./buildconf
it complains of my acconfig.h.. for the autoconf stuff???

Here's the output:

eskimo [359] ./buildconf
Creating include/private/apu_config.h ...
autoheader: `include/private/apu_config.h.in' is unchanged
Creating configure ...
Invoking xml/expat/buildconf.sh ...
Incorporating /usr/local/share/aclocal/libtool.m4 into aclocal.m4 ...
Copying libtool helper files ...
Creating config.h.in ...
WARNING: Using auxiliary files such as `acconfig.h', `config.h.bot'
WARNING: and `config.h.top', to define templates for `config.h.in'
WARNING: is deprecated and discouraged.

WARNING: Using the third argument of `AC_DEFINE' and
WARNING: `AC_DEFINE_UNQUOTED' allows to define a template without
WARNING: `acconfig.h':

WARNING:   AC_DEFINE([NEED_MAIN], 1,
WARNING:             [Define if a function `main' is needed.])

WARNING: More sophisticated templates can also be produced, see the
WARNING: documentation.
autoheader: `config.h.in' is unchanged
Creating configure ...

Then when I run ./configure it cannot find the install-sh:

eskimo [361] ./configure
configure: error: cannot find install-sh or install.sh in ../apr/build
./../apr/build

..and it's looking in the wrong directory (?)

Please help! Thanks! ;-)


-- Trev

Mime
View raw message