apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Stein <gst...@lyra.org>
Subject Re: arch specific include files, the naming thereof
Date Mon, 06 Jan 2003 03:45:04 GMT
On Sun, Jan 05, 2003 at 11:45:17PM +0000, Thom May wrote:
> the header files in include/arch/*/* currently have very generic names, like
> "dso.h". I got bit by this earlier when trying to specify the location of
> OpenSSL, which also ships a dso.h
> Would anyone have any objections to renaming them as
> apr_*_private.h/apr_private_*.h ?
> I volunteer to do it, just wondering if people have reasons not too?

Drop the "private" part. They're already private based on where they're
located, so there isn't a need to further qualify them. I'm also assuming
that we can manage to avoid conflicts between the arch-specific and the
public file names (since we manage both namespaces).


+1   on using apr_*.h
+0.2 on using apr_priv_*.h
+0   on using apr_private_*.h
-0   on using apr_*_private.h


Greg Stein, http://www.lyra.org/

View raw message