apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thom May <t...@planetarytramp.net>
Subject Re: Apache release compatibility, WAS: RE: svn commit: rev 4239 - trunk/subversion/libsvn_subr
Date Fri, 03 Jan 2003 21:46:53 GMT
> 
> That's going to be interesting from the Subversion perspective though.  We 
> may be forced *not* to use APR 1.0 because httpd-2.0 won't work with it. 
> It's fun, isn't it?  Perhaps we'll relax this policy and not drop 
> deprecated functions until APR 2.0, but that's an awful lot of cruft to 
> keep around for a long time.  -- justin

I'm beginning to think that keeping the deprecated functions around until
2.0 is going to be our best plan; that way httpd-2.0 can track apr-1.0.x;
without having to have every change that requires it backported to the
version it gets fixed at. Also, it takes some of the pain away from
developers of client apps...
Cheers,
-Thom

Mime
View raw message