apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "D. Fairbanks" <da...@rivertonmotor.com>
Subject mod_perl 2.0 trouble compiling = cannont find -lapr -laprutil
Date Fri, 13 Dec 2002 23:57:12 GMT
Hello & Happy Holidays,

I'm also having trouble with mod_perl compiling.  I know I risk RTFM
replies.  I just don't know where else to ask.  If I'm missing some already
posted info, please point me there and accept my appologies.

I'll confess I'm very new to this but I've spent the past six months
studying and building and resolving myriad confilcts and dependancies on
this server:

Red Hat v8.0
Apache v2.0.43
perl v5.8.0
gcc v 3.2 (2002 09 03)
mod_perl 2.0 (nee 1.99_07)
apr 0.9.1
apr-util 0.9.1

(I must confess that if I hadn't seen the rock-solid stability of xnix OS's
I'd have given up long before now.  The dependancy ride-go-'round with lib's
and versions of gcc and required modules and varying versions of other OS
components and programs has left me weary indeed and almost willing to give
over the the dark side and consider M$ platforms instead of my LAMPS (Linux
Apache MySQL PHP server).  Please help a green accolyte keep his faith.
"The path of the way must challenge in order to foster growth and strength,
but it must not crush nor kill.")

In addition I've started from a clean install with updates (I do know this
can be bad.) downloaded all of these components and updated from cvs today
(13 DEC 2002).

Yet...

I receive the following after ./config'ing mod_perl:

># make
...
gcc -c  -I/usr/local/src/LAMPS/mod_perl/mod_perl-1.99_07/src/modules/perl -I
/usr/local/src/LAMPS/mod_perl/mod_perl-1.99_07/xs -I/usr/local/apache2/2.0.4
3/include -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing  -I/usr/include/gd
bm -DMOD_PERL -O2 -march=i386 -mcpu=i686   -DVERSION=\"0.01\" -DXS_VERSION=\
"0.01\" -fpic "-I/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE"   APR.c
Running Mkbootstrap for APR ()
chmod 644 APR.bs
rm -f ../../../blib/arch/Apache2/auto/APR/APR.so
LD_RUN_PATH="/usr/lib" gcc  -shared -L/usr/local/lib APR.o  -o
../../../blib/arch/Apache2/auto/APR/APR.so   -L/usr/local/apache2/2.0.43/lib
 -lapr -laprutil
/usr/bin/ld: cannot find -lapr
collect2: ld returned 1 exit status
make[3]: *** [../../../blib/arch/Apache2/auto/APR/APR.so] Error 1
make[3]: Leaving directory
`/usr/local/src/LAMPS/mod_perl/mod_perl-1.99_07/xs/APR/APR'
make[2]: *** [subdirs] Error 2
make[2]: Leaving directory
`/usr/local/src/LAMPS/mod_perl/mod_perl-1.99_07/xs/APR'
make[1]: *** [subdirs] Error 2
make[1]: Leaving directory
`/usr/local/src/LAMPS/mod_perl/mod_perl-1.99_07/xs'
make: *** [subdirs] Error 2
>#_

I've read the dialog between Benny Jensen and Stas Bekman from:

http://mathforum.org/epigone/modperl/tendprerplu/3DE5DDDE.90602@stason.org

I've checked my Apache/Perl install three times against:

http://perl.apache.org/docs/2.0/user/install/install.html#Condiguring_and_In
stalling_Prerequisites

And I've had an "Apache Head" check my installs, configs, versions, lib's &
processes.
So far everything checks out fine.  !?!  But, mod-perl still won't compile
and neither will apr-util.

When ./configure'ing the newest apr-util I get:

>#./configure
...
./configure: line 1278: syntax error near unexpected token `config.nice'
./configure: line 1278: `APR_CONFIG_NICE(config.nice)'
>#_

Mr.  Bekman, can you kindly tell me what you recommend I "get the latest
cvs" of?  Did you mean mod_perl, libapr, Apache, or something else, or all
of these?  What was the broken build of?  How do I mend it?  I've tried the
latest versions of these from CVS but get the same errors.

Mr.  Jensen, what did - if anything did - solve your problem?

Thanks all for your kind consideration and in advance for any help you can
provide.

Your humble student,

Daren Fairbanks




Mime
View raw message