apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Bannert <aa...@clove.org>
Subject Re: [PATCH] new Resource List interface for apr-util
Date Mon, 05 Aug 2002 02:58:25 GMT
On Sat, Aug 03, 2002 at 12:57:12PM -0700, Pier Fumagalli wrote:
> It looks great... The only "nitpick" I might have to make (forgot to tell
> you earlier) is that instead of apr_reslist_get and apr_reslist_put, those
> should be called apr_reslist_acquire and apr_reslist_release, like in locks,
> because this is what we do (we acquire a resource, locking it intrinsically,
> and release it after we're done with it).
> Get and put (especially put) seems to imply that I can create a resource,
> and put it in the list, while we want to use the constructor and destructor
> functions... :)

Sounds totally reasonable to me, I'll do the rename and commit it to
CVS tonight.


View raw message