apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <jwool...@virginia.edu>
Subject Re: next steps for changing apr_time_t?
Date Mon, 08 Jul 2002 17:06:41 GMT
On Mon, 8 Jul 2002, Tony Finch wrote:

> I note that apr_time_t is a bad name in the first place, because POSIX
> reserves all names ending in _t for the implementation. Feel free to
> ignore this exceedingly irritating naming rule :-)

I think we uniformly ignore this rule already.  Everything in APR that I
know of already has a _t suffix (APR-util doesn't follow this standard
consistently -- many things in APR-util, including buckets, XML stuff, and
strmatch patterns, leave off the _t).  I remember when we had this
discussion last, and as I recall, everybody agreed it was a stupid rule.


View raw message