apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Saccoccio" <r...@fastcgi.com>
Subject apr-util/xml/expat/buildconf.sh
Date Thu, 25 Jul 2002 00:39:13 GMT
This change is required for apr-util/xml/expat/buildconf.sh as well.

--rob

> -----Original Message-----
> From: Rob Saccoccio [mailto:robs@fastcgi.com]
> Sent: Tuesday, July 23, 2002 8:13 AM
> To: dev@apr.apache.org
> Subject: [PATCH] apr/buildconf
> 
> 
> A non-standard libtool installation tree confuses apr's buildconf.
> 
> The 'cd $ltpath/../share/aclocal' fails because the dir doesn't exist.
> 
> The approach below seems more reasonable.  The '^datadir=' 
> pattern is always
> present (>5yrs).
> 
> I left the current approach in as a fallback.
> 
> --rob
> 
> 
> diff -u -r1.24 buildconf
> --- buildconf   15 May 2002 16:47:09 -0000      1.24
> +++ buildconf   23 Jul 2002 03:59:44 -0000
> @@ -80,12 +80,15 @@
> 
>  $libtoolize --copy --automake
> 
> -ltpath=`dirname $libtoolize`
> -ltfile=`cd $ltpath/../share/aclocal ; pwd`/libtool.m4
> -
> +ltfile=`awk '/^datadir=/ { print substr($1, 9); }'
> $libtoolize`/aclocal/libtool.m4
>  if [ ! -f $ltfile ]; then
> -    echo "$ltfile not found"
> -    exit 1
> +    ltpath=`dirname $libtoolize`
> +    ltfile=`cd $ltpath/../share/aclocal ; pwd`/libtool.m4
> +
> +    if [ ! -f $ltfile ]; then
> +        echo "libtool.m4 not found"
> +        exit 1
> +    fi
>  fi
> 
>  cat $ltfile | sed -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' >
> build/libtool.m4
> 
> 
> 

Mime
View raw message