apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Fogel <kfo...@newton.ch.collab.net>
Subject Re: proposal to add apr_check_dir_empty() to APR
Date Tue, 02 Jul 2002 21:00:01 GMT
"William A. Rowe, Jr." <wrowe@rowe-clan.net> writes:
> One, the name sucks... perhaps apr_dir_is_empty()?  Keep it named with the
> other apr_dir_ family members and our general schema.  We have to work hard
> on consistency so we avoid symbol renames of newly created functions.

I've changed it to apr_dir_is_empty() in the Subversion sources, so it
will be that name when we port it over to APR.

> Other than that, I would _NOT_ assume all first two entries are "."/"..", but
> if you make that an explicit string test, I'd be +1.

Fixed now.

> Also, APR_EGENERAL seems a bit vague, how about APR_EEXISTS?

We should either make a new status code explicitly for this, or return
via an int* parameter.  Personally I think the int* solution is
cleaner: the function should return an error status iff something went
wrong, and use an entirely separate channel for returning the answer.

Would anyone object to this solution?


View raw message