apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: cvs commit: apr STATUS
Date Sat, 13 Jul 2002 02:05:42 GMT
At 08:49 PM 7/12/2002, fielding@apache.org wrote:
>          2) Renaming the function to get rid of apr_time_t vs time_t 
> confusion,
>             but keep it ambigious and make no contract with the user 
> about the
>             units represented.  Needs a better suggestion than apr_timeval_t.
>   -         +1: aaron, brianp, ianh
>   +         +1: aaron, brianp, ianh,
>   +             fielding [prefers apr_time and apr_span (_t is half the 
> problem)]

Just as a point of reference, we have adopted _t for all types in APR by
convention.  If this is our type, it needs an apr_ prefix and _t suffix.

That's just the way the library has evolved.  Screw the '_t is reserved to
the implementation' when we've already gone and apr_ decorated it all.
As soon as a vendor comes out with an apr_foo_t type... we can all
chuckle.

Bill



Mime
View raw message