apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Garrett Rooney <roo...@electricjellyfish.net>
Subject problem with apr_atomic_init on freebsd
Date Fri, 05 Jul 2002 19:23:22 GMT
so for the first time in like forever, i reinstalled my development
machine and thus had to download fresh copies of subversion and apr.

it seems that apr's configure script is now disabling threads by
default on FreeBSD, which is fine, since i'm not actually using
threads, but there appears to be a few kinks with the atomics code.

if i don't pass '--enable-threads' to configure, when i get around to
compiling subversion it fails to link because it's looking for
apr_atomic_init. 

here's the error i get:

cd subversion/clients/cmdline && /usr/local/bin/bash /home/rooneg/svn/libtool --silent
--mode=link  gcc -D_REENTRANT -D_THREAD_SAFE  -g -Wall -Wmissing-prototypes -Wstrict-prototypes
-Wmissing-declarations -DNEON_SSL -Wpointer-arith -Wwrite-strings -Wshadow -DSVN_DEBUG -DAP_DEBUG
  -I./subversion/include -I.  -I/usr/home/rooneg/svn/apr/include -I/usr/home/rooneg/svn/apr-util/include
-I/home/rooneg/svn/apr-util/include -I/usr/local/include/db4 -I/usr/local/include -I/usr/local/include/neon
-I/usr/local/include/db4 -L/usr/local/lib  -rpath /usr/local/lib -o svn  add-cmd.o checkout-cmd.o
cleanup-cmd.o commit-cmd.o copy-cmd.o delete-cmd.o diff-cmd.o export-cmd.o feedback.o help-cmd.o
import-cmd.o info-cmd.o log-cmd.o main.o merge-cmd.o mkdir-cmd.o move-cmd.o prompt.o propdel-cmd.o
propedit-cmd.o propget-cmd.o proplist-cmd.o props.o propset-cmd.o resolve-cmd.o revert-cmd.o
status-cmd.o status.o switch-cmd.o update-cmd.o util.o ../../../subversion/libsvn_client/libsvn_client-1.la
../../../subversion/libsvn_wc/libsvn_wc-1.la ../../../subversion/libsvn_ra/libsvn_ra-1.la
../../../subversion/libsvn_delta/libsvn_delta-1.la ../../../subversion/libsvn_subr/libsvn_subr-1.la
/usr/home/rooneg/svn/apr-util/libaprutil.la -lexpat /usr/home/rooneg/svn/apr/libapr.la -L/usr/local/lib
-lneon -lssl -lcrypto -L/usr/local/lib -lexpat -lm -lcrypt
/usr/home/rooneg/svn/apr/.libs/libapr.a(start.o): In function `apr_initialize':
/usr/home/rooneg/svn/apr/misc/unix/start.c(.text+0x6f): undefined reference to `apr_atomic_init'
*** Error code 1

Stop in /usr/home/rooneg/svn.

it seems like apr_atomic_init should be #defined to APR_SUCCESS in the 
non-threads case or something like that, but after tracing through header 
files for far too long trying to figure out what the hell was going wrong, 
i've got too much of a headache to figure out what the appropriate fix is.

if someone who's a little more familiar with this code could give it a
look, i'd be quite appreciative.

thanks,

-garrett

-- 
garrett rooney                    Remember, any design flaw you're 
rooneg@electricjellyfish.net      sufficiently snide about becomes  
http://electricjellyfish.net/     a feature.       -- Dan Sugalski

Mime
View raw message