apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@attglobal.net>
Subject Re: apr_private.h not being built properly on daedalus (freebsd 4.6) today
Date Thu, 27 Jun 2002 21:29:40 GMT
Jeff Trawick <trawick@attglobal.net> writes:

> The header file defines in apr_private.h are busted and APR won't
> build.  Here is a glaring example:
> 
> /* Define if you have the <string.h> header file.  */
> /* #undef HAVE_STRING_H */
> 
> config.cache seems to have the right value:
> 
> ac_cv_header_string_h=${ac_cv_header_string_h='yes'}

I tried installing local copies of GNU m4 and autoconf 2.13, but the
problem persists.  I even tried specifying /usr/local/bin/bash instead
of /bin/sh in configure.  Any other ideas to narrow down what broke
it?

Oh, we aren't finding sockaddr_in6 today either.

Greg has a stashed build tree, and we're going to need to compare old
and new apr.h and apr_private.h to see what else has gone haywire.
-- 
Jeff Trawick | trawick@attglobal.net
Born in Roswell... married an alien...

Mime
View raw message