apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@attglobal.net>
Subject Re: apr_private.h not being built properly on daedalus (freebsd 4.6) today
Date Thu, 27 Jun 2002 22:10:00 GMT
Justin Erenkrantz <jerenkrantz@apache.org> writes:

> > I tried installing local copies of GNU m4 and autoconf 2.13, but the
> > problem persists.  I even tried specifying /usr/local/bin/bash instead
> > of /bin/sh in configure.  Any other ideas to narrow down what broke
> > it?
> 
> By chance, do you have AUTOCONF or AUTOHEADER set as environment
> variables?  You can also set them to explicit paths.  It's
> possible that they are in conflict.  -- justin

no, I had played with those earlier but they were definitely unset in
my last test....

this might be a clue...  I killed a configure after it had detected
headers and I had this in confdefs.h:

#define HAVE_SYS_IPC_h 1
#define HAVE_SYS_SHM_h 1
#define HAVE_SYS_FILE_h 1

This error is probably what is breaking IPv6 detection and may be
breaking the other stuff too.

I probably should have tried GNU sed instead of FreeBSD sed.

(suffering from Chinese food deficit)
-- 
Jeff Trawick | trawick@attglobal.net
Born in Roswell... married an alien...

Mime
View raw message