apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Mankin <man...@ants.com>
Subject Re: [APR PATCH] Bootstrapping problem on Mac OS X
Date Mon, 10 Jun 2002 18:09:27 GMT
On Mon, 10 Jun 2002, Justin Erenkrantz wrote:

> On Mon, Jun 10, 2002 at 01:44:05AM -0700, David Mankin wrote:
> >
> > This weekend I tried to bootstrap subversion from the r1868 tarball.
> > However, I ran into a Mac OS X related stopper.  Every time I tried to
> > run svn to checkout the repository, it exited with this error:
> >
> > dyld: svn can't open library: libsvn_ra_local.so  (No such file or directory, errno
= 2)
> >
> > I configured and built svn with the --enable-maintainer-mode and
> > --disable-shared.
>
> Please try with the latest of APR and SVN (remember a bootstrap
> isn't meant to do anything other than get the latest of SVN).  There
> have been some fixes to APR's handling of Darwin DSOs recently.  I'm
> not sure if it fixes this or not, but it might.  Please try that
> though.

I haven't tried it with the latest APR and SVN yet (It took me all
weekend to get the bootstrap to bootstrap), but I did check the HEAD of
APR in CVS and the code in question hasn't changed substantially since
the version rolled in the SVN tarball.  So, I'm pretty sure that I'll be
able to reproduce it, but won't be able to try until later this evening.

> I believe that Pier's patch that we added to call NSAddLibrary is a
> tad bogus.  I think it should only call NSAddLibrary if and only if
> NSCreateObjectFileImageFromFile returns NSObjectFileImageFormat.
> That would be my guess as to Pier's failure case for loading
> the JVM shared libraries.  (Pier, if you are reading this, can you
> please check if this is indeed what is returned?  I don't know how
> to reproduce your case.)

I don't know enough about Darwin library loading to comment, but it does
look a little strange.

> I will attempt to reproduce this later tonight.  My problem with
> OS X and SVN is that the DAV client does not work properly.  This
> problem is nasty to investigate because the process enters an
> unkillable state where I can't do anything to it except reboot
> the machine.  -- justin

-David Mankin


Mime
View raw message