apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <jwool...@virginia.edu>
Subject Re: apr_time_t --> apr_time_usec_t
Date Mon, 10 Jun 2002 23:24:25 GMT
On Mon, 10 Jun 2002, Aaron Bannert wrote:

> On Mon, Jun 10, 2002 at 03:57:29PM -0700, Justin Erenkrantz wrote:
> > How about using the value we already have:
> >
> > typedef apr_int32_t apr_short_interval_time_t;
>
> Unfortunately, that type still has units of milliseconds.
> Seems like Roy needs an "apr_seconds_t", and apr_short_interval_time_t
> should be renamed "apr_milliseconds_t".

No, MICROseconds.  For both of them.

apr_time_t: a 64 bit quantity specifying microseconds since the epoch
apr_interval_time_t: a 64 bit quantity specifying the microsecond
                     difference between two apr_time_t's.
apr_short_interval_time_t: a 32 bit quantity specifying the microsecond
                           difference between two apr_time_t's that are
                           very close together (what is it, like 36
                           minutes max?)

If you want some of those to be seconds or some alternative ones to be
seconds, fine, but let's be precise.  :)


Mime
View raw message