apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Pane <bp...@pacbell.net>
Subject Re: [PATCH] apr_file_setaside
Date Sun, 30 Jun 2002 01:35:21 GMT
Cliff Woolley wrote:

>On Sat, 29 Jun 2002, Brian Pane wrote:
>>Which dup() do you mean: the dup(2) or the naming convention of
>>using "_dup*()" for this family of apr_file_t functions?
>Sorry, I should have been more precise.  apr_file_dup() was what I was
>referring to.
>On second thought though, I suppose I wouldn't object to
>apr_file_setaside() if we changed apr_mmap_dup() to be apr_mmap_setaside()
>as well... would that make sense?  I'm just looking for consistency here,
>not objecting to the concept.

I agree: using apr_mmap_setaside() for consistency would make
sense.  We probably need to keep apr_mmap_dup() for backward
compatibility, but we could do this:

#define apr_mmap_setaside(new, old, pool) apr_mmap_dup(new, old, pool, 1);
  /* the '1' at the end is the "transfer ownership" flag


View raw message