apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pier Fumagalli <p...@betaversion.org>
Subject Re: can we require libtool 1.4 ?
Date Tue, 14 May 2002 08:30:56 GMT
"Greg Stein" <gstein@lyra.org> wrote:

> libtool 1.3 has problems with intra-library dependencies. This is making
> some of the dependency stuff in apr(-util) a bit more complicated than it
> needs to be.
> 
> The simple answer is to require libtool 1.4.
> 
> Subversion has been on libtool 1.4 since last October. After some initial
> grumbling, there hasn't been *any* problem with people complaining about not
> having libtool 1.4 available.
> 
> I think it would simplify our life, and give us proper dependencies, yet not
> cause any undue burden (libtool 1.4 has been out for a long while now...)
> 
> From IRC, I already have a +1 from Justin and Sander. So I'd say we have
> enough positive traction for the move. But does anybody see any *problems*
> or have a reason to *not* require 1.4 ?

+1 on MacOS/X LibTool needs to be upgraded anyway to fix some bugs with the
one shipped with the OS, and 1.4.2 (patched) runs just fine...

    Pier


Mime
View raw message