apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Stein <gst...@lyra.org>
Subject Re: can we require libtool 1.4 ?
Date Tue, 14 May 2002 18:48:06 GMT
On Tue, May 14, 2002 at 11:15:18AM -0400, Garrett Rooney wrote:
> On Tue, May 14, 2002 at 07:45:37AM -0700, Aaron Bannert wrote:
> > On Tue, May 14, 2002 at 12:44:33AM -0700, Greg Stein wrote:
> > > libtool 1.3 has problems with intra-library dependencies. This is making
> > > some of the dependency stuff in apr(-util) a bit more complicated than it
> > > needs to be.
> > > 
> > > The simple answer is to require libtool 1.4.
> > 
> > Are there any platforms do _not_ support libtool 1.4 or have problems
> > with it?
> 
> The FreeBSD ports tree doesn't yet support libtool 1.4 (it's an

'ports' may not have it, but libtool 1.4 works fine on FreeBSD. Ben
Collins-Sussman and yourself build Subversion on FreeBSD all the time, and
that requires 1.4.

>...
> no problem with just installing it yourself.  Requiring 1.4 means that
> anyone developing on FreeBSD will have to install a custom libtool,
> which is irritating, but not a show stopper.  It will create some

Right.

> problems with the way the current FreeBSD port of apr works, but
> nothing unsolvable (i think).

Then we'll simply need to fix the APR port, huh? :-)

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

Mime
View raw message